MindsDB with a config version 1.1, custom datastore specified leads to error in shutil

MindsDB Service Desk
Here is the problematic config (most of it is from MariaDB AITables),{,“api”: {,“http”: {,“host”: “0.0.0.0”,“port”: “47334”,},“mysql”: {,“certificate_path”: “path/to/cert”, ,“host”: “127.0.0.1”,“log”: {,“console_level”: “INFO”,“file”: “mysql.log”,“file_level”: “INFO”,“folder”: “logs/”,“format”: “%(asctime)s - %(levelname)s - %(message)s”,},“password”: “root”,“port”: “47335”,“user”: “pass”,},},“config_version”: “1.1”,“debug”: true,“integrations”: {,“default_mariadb”: {,“enabled”: true,“host”: “localhost”,“password”: “password”,“port”: 3306,“type”: “mariadb”,“user”: “root”,},},“interface”: {,“datastore”: {,“enabled”: true,“storage_dir”: “./mindsdb-datastore”,},“mindsdb_native”:{,“enabled”: true,“storage_dir”: “./mindsdb-native”,},},},This will prevent MindsDB from starting, the error is:,[Errno 2] No such file or directory: ‘/tmp/tmplcnx3g92/datastore’,The problem seems to be that the migration function (to 1.2 version) assumes that the datastore directory will only be called ‘datastore’, not any other name, like in the config I pasted.

We are working on a fix for this.

We have released a new version of 2.9.1 with a fix about configuration issues. In case someone is still experiencing the above or similar issues, our recommendation is for you to delete all folders related to the datastore or storage_dir, and re-start MindsDB.